PoshBoard 2.5 problem

May 22, 2010 at 8:53 AM

I've installed PoshBoard on Windows Server 2003 as described in instruction, but when i connect to the created site it stops on 100% and nothing happens.

Coordinator
May 22, 2010 at 4:50 PM

Hi,

what is the language of your operating system ?

did you install properly the .net 3.5 SP1 framework with WCF addition ?

 

this problem is either due to improper configuration of the security (PoshBoard assume that the OS is in english, you need to modify poshboard.config with proper group if you have a different language), or a problem with WCF

try to connect to the service to see if it works :  http://yourPoshBoardAddress/PoshBoardService.svc

May 23, 2010 at 1:51 AM

Thank you for a quick reply.

The language of OS is russian. .Net framework 3.5 sp1 is installed. The service works (PowerShellService.svc), it renders html page with example.

Where can I find poshboard.config?

Coordinator
May 23, 2010 at 8:07 AM

Ok if it's in russian, all you have to do is replace "everyone" group in the poshboard.config with the name of the everyone group in russian and it should be ok.

 

the poshboard config file is called "PoshBoardWebConfig.xml" in the root of poshboard web site

May 23, 2010 at 1:41 PM

Works! Great!

 

Aug 19, 2010 at 12:38 PM
Edited Aug 19, 2010 at 12:42 PM
i have same issue. but replacing "everyone" group in the poshboard.config with the name of the everyone group in russian does not help. when i try http://localhost/PowerShellService.svc - seems ok, page displayed, but http://localhost - 100% and white page. how can i test, is an net 3.5 sp1 is installed? and one more thing. this server is in domain, and i cant ctreate a app pool using local user credentials, system does not allow this. my system is win2k8 r2 std x64 russian on vmware esxi 3.5.
Coordinator
Aug 19, 2010 at 1:10 PM
eosfor, Please note that group name are case sensitive, it seems to me that you just forgot Uppper/lower caracter for Everyone in russian.
Aug 19, 2010 at 2:20 PM
:( not work. can you connect using rdp to this server, and i connect to you session to see what you are doing?
Coordinator
Aug 19, 2010 at 2:48 PM
you can check in Add/Remove programs if .NET 3.5 SP1 is installed, but for me it's OK cause you should have errors prior to this point. Verify that your service account as full control on the PoshBoard directory, check also that you properly set up Anonymous authentication (using the Application pool account) and that Windows Authentication is enabled. Change everyone with another group where your user account is in (Domain\GroupName, all case sensitive) I cannot do RDP with you at this time cause I'm quite busy sorry
Aug 19, 2010 at 4:21 PM
hmm, it is really because of russian system and domain objects. i have delete all of chars except first one and change config to : <?xml version="1.0" encoding="utf-8"?> <Configuration> <Admins> <Member Name="DOMAIN\Administrator" MemberType="User" /> </Admins> <Script> <Name>Chart : Basic Chart</Name> <AccessList> <Member Name="DOMAIN\Administrator" MemberType="User" AccessType="Administrator" Default="False" Impersonate="True" LiveUpdate="True" /> </AccessList> <Height>0</Height> $chart = new-pbchart -name chart -Title MyChart -Theme Theme3 $random = new-object System.Random $a = new-pbChartserie -name test -renderas column $a.AddDataPoint("Data 1",$random.Next(100)) $a.AddDataPoint("Data 2",$random.Next(100)) $a.AddDataPoint("Data 3",$random.Next(100)) $a.AddDataPoint("Data 3",$random.Next(100)) add-pbchartseries $chart $a $chart </Script> </Configuration> and its work fine. can you explain why this happens
Aug 19, 2010 at 4:37 PM
Edited Aug 19, 2010 at 7:55 PM
is it possible to use sids, not user or group names in such cases? PS. really groups are case sensitive. "Domain admins" does not work, but "Domain Admins" works fine! Why?
Nov 4, 2010 at 3:46 PM

Hi,

 

I've the same problem (created site stops on 100% and nothing happens) and I'm on Windows Vista SP1. I've followed Installation Guide.

.Net framework 3.5 sp1 is installed and my OS is in english. PoshBoardService.svc doesn't exists in my poshboard folder. I've tried with PowerShellService.svc but I get this error :

HTTP Error 404.3 - Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

 

Any ideas ?

Jul 2, 2011 at 4:54 PM

vinz2k,

I was having the same problem.

After a couple hours of brute forcing this problem, I found the solution to the (poshboard 100% and nothing happens) problem.

1. open a command prompt on your webserver (as administrator)
2. Navigate to C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation.
3. Run this command servicemodelreg –i.

http://blogs.msdn.com/b/rjohri/archive/2009/06/29/the-page-you-are-requesting-cannot-be-served-because-of-the-extension-configuration.aspx